The easiest way to check to see if the Geckodrive G540 is working correctly is to connect only your power supply, a jumper wire between TERMINAL 10 and 12 and turn off the charge pump switch on the front of the drive.

With only those things done you should get a green LED. If you do, begin plugging in your motors one by one to see if the problem is emanating from one axis.

Should no LEDs turn on you will need to remove the cover and check fuse continuity. The fuse will be located on the motherboard near TERMINALs 11 and 12 and will look like a green 1/4W resistor.

It will be socketed to allow for easy removal, and all you need to do is test it with an ohmmeter. A reading of zero ohms (or close to that) means it is okay; a reading of an open circuit means it has blown and should be replaced.

If the red LED stays on regardless of the setup then I would recommend taking the cover off and removing the motherboard from the G250XR3 drives inside.

Plug it in the same way as previously described and see if you get a green LED. If you do, then you will want to plug each G250XR3 in individually (powering off while plugging them in) and seeing if you get a green LED with each one.

Eventually, you will find one that is causing the motherboard to go into FAULT. When you find that one you can send it back to us for evaluation and repair.

Please follow this link and complete the form to receive an RMA number.

Most product returns take around 5 business days but may take longer depending on workload. All drives still covered under warranty are evaluated and repaired free of charge if there is no board-level damage and include free return shipping within the USA.

Some repair charges may apply to drives out of warranty and those with customer induced damage. We will contact you as soon as your drive has been evaluated and if there are any questions from our engineering team.

We also have a video on how to troubleshoot your G540: